Error Message
"A customer exists with the same name as vendor X. Please rename the customer or vendor and retry"
Cause
QuickBooks Desktop requires that display names be unique across customers and vendors. In this case, the accounting connector is trying to add or update a vendor into QuickBooks Desktop with the same display name as a customer already in QuickBooks Desktop.
Resolution
To resolve this, you will either have to change the name of the Vendor in ServiceBox to something unique, or change the name of the customer in QuickBooks Desktop.
NOTE: If the customer with the same display name in QuickBooks Desktop is one that was sync'd with ServiceBox, the correct procedure to change their name is to change it in ServiceBox first, then have the accounting connector update the name in QuickBooks Desktop.