Error Message

The customer in accounting with the name X is already linked to a customer (named: Y) in ServiceBox.

Cause

This can happen if, on a customer in QuickBooks Online that is already linked to a ServiceBox customer, is changed to have the same name as a different customer in ServiceBox. The system cannot link the new customer to the QuickBooks Online customer because of the existing linkage to the QuickBooks Online customer.


Resolution

To resolve this, you will have to do one of the following:

  1. go to either change the name of the customer in QuickBooks Online to match the customer they are already linked to (as specified in the message).
  2. Unlink the customer in ServiceBox that the QuickBooks Online customer is are already linked to so the new customer can be linked to the QuickBooks Online Customer.
  3. Change the name of the customer in ServiceBox so that the sync can create a new customer in QuickBooks Online.