Message

Could not find customer X for invoice Y (ServiceBox Invoice Y)

Cause

The reason for this is that the connector is not able to look up the customer in Sage with the last known name in ServiceBox. When a customer is imported into Sage using the connector, ServiceBox stores in the background the display name of the customer. This is ServiceBox's link to the Sage Customer. If the customer's name is changed manually in Sage (ie: Not by changing it in ServiceBox then syncing to sage), the link is broken.


Resolution

To fix this, change the customer's display name in ServiceBox to match the Sage customer name, then unlink the customer in ServiceBox and re-sync.