Issue:
Some clients have reported that their ServiceBox users are experiencing difficulties editing the labor hours in the T&M (Time and Materials) section. When attempting to make changes to the labor hours, they encounter an error message.
Cause:
The root cause of this issue is that basic users/technicians do not have the permission to change labor hours by default. On the other hand, Office Users and Administrators usually have the ability to modify labor hours. If Office users and/or administrators are unable to edit labor hours, it is likely due to access role settings for the user's role. Specifically, the 'Users role' lacks the necessary access level to 'edit submitted timesheets,' resulting in error messages when attempting to modify the labor hours.
Solution:
If you would like your basic user to have permission to edit labor hours, send the request to our support team at [email protected]. The support team will make the necessary adjustments to the access role settings in ServiceBox and grant users the permissions required to edit submitted timesheets.
Contact our support team at [email protected] if Office Users are not able to edit labor hours.