Issue:

Some customers reported an error "Error adding item labor - Tech2; BadRequest. Details: The name already exists" during the sync process of invoices with QuickBooks Online.

Cause:

The error occurs when there are spaces before and after the dash in the line item names used on the invoices. For example, the line item appeared as "Labor - tech1," causing synchronization problems.

Solution:

To resolve the syncing issue, necessary adjustments should be made by removing the spaces from the line items under "Settings > Quote Items." 

Here is the step by step process:

  • Log in to ServiceBox with appropriate credentials.
  • Navigate to the "Settings" section, located in the top right corner of the screen.
  • Go to "Quotes" tab and click on "Quote Items" 
  • Identify line items with names containing spaces before and after the dash, like "Adding - New item"




  • Click on "Edit" button to manually remove the spaces before and after the dash, ensuring the line item reads as "Adding-new item"




  • Click on Green Checkmark to to save the changes made to the line item. 




  • Check other line items for a similar format with spaces before and after the dash.
  • Repeat the same process for each line item with spaces to remove them.
  • You should be able to sync all invoices after updating line items to remove spaces before and after spaces. 


If you have any further questions or encounter any difficulties, don't hesitate to reach out to the ServiceBox support team [email protected]