Error Message
"You are attempting to run the connector against a Sage file other than the last opened file. This is not valid. Please make sure the file set up in Settings is the file you want to sync to..."
Cause
We have consistently found that if the Sage 50 file set up in settings is different from the last file opened in Sage, that the reason for this is that a back up was restored to a new Sage file and if the sync was allowed to continue, records from ServiceBox would be going into the old file, not the new file.
Resolution
To resolve this, either open the file you want to sync in Sage 50 if the file identified in Settings is correct, or if there is a new file to be sync'd to, go into Settings and click the 'Detect' button next to the Sage 50 file which should populate the field with the latest file opened.